Page 1 of 1

Pirate Trajectory Issue

PostPosted: Sat Feb 27, 2016 12:39 pm
by cheers
For some reason, one of my pirates won't properly target subs. It never let's me actually lock onto the sub, although the pirate will ultimately target the sub, but then the trajectory is an arc rather than a straight line. This causes the pirate to miss the sub and turn around. Strangely, my other pirate works just fine. I have a video of the behavior, but it doesn't seem like I can attach it here. If anyone has a tip how to post the video, let me know! Hoping someone can help with my dud pirate! :?:

http://youtu.be/E-fL9kX7Hok

Edit: Added YouTube link to the video

Re: Pirate Trajectory Issue

PostPosted: Sat Feb 27, 2016 4:35 pm
by pandasecret
Pirates won't lock on if they won't be able to reach the sub in time (either the sub arrives at an outpost before pirate can get there or it gets a speed boost like an admiral global), so it won't follow. It will go the opposite direction if this is the case.

Re: Pirate Trajectory Issue

PostPosted: Sat Feb 27, 2016 8:46 pm
by tw2000
pandasecret wrote:Pirates won't lock on if they won't be able to reach the sub in time (either the sub arrives at an outpost before pirate can get there or it gets a speed boost like an admiral global), so it won't follow. It will go the opposite direction if this is the case.

Not neccesarily, sometimes it will go the long way, but often it will 'retarget' the sub every tick, causing it to travel a course which looks like an arc.
Anyway, A good way of determining if a pirate will be able to reach its target in time is to see how long it takes your pirate to get the the same outpost that the sub you're trying to target is going to. If the time taken is more than twice that of the sub you're trying to target, you won't be able to target it. In some extreme cases, even though it looks like the pirate will make it with a few minutes to spare, it might not work for reasons concerning game mechanics (it is NOT a bug usually...)

Re: Pirate Trajectory Issue

PostPosted: Sun Feb 28, 2016 11:41 am
by v3xt
If you want to post a video, most people upload it to youtube and then just paste a link here.

Re: Pirate Trajectory Issue

PostPosted: Sat Mar 05, 2016 1:29 pm
by cheers
Thanks for the upload tip! Here's the link to the video:

http://youtu.be/E-fL9kX7Hok

Anyone else having this issue?

Re: Pirate Trajectory Issue

PostPosted: Sat Mar 12, 2016 7:21 pm
by v3xt
Oh, I've seen this before. The problem is actually that your pirate was able to target it in the first place. It can't intercept the sub before it arrives, so it just retargets every tick and aims directly at it, meaning it never gets there in time.

Re: Pirate Trajectory Issue

PostPosted: Fri Apr 01, 2016 7:12 pm
by dibididoo
I've had this issue more than once and have posted here about it. I'm not sure whether it's a big or not. It seems like if the pirate will not be able to reach its target or if it instead retargets the sub every tick (forming a curved trajectory) that the pirate should not be able to launch at all. I think this only happens however when targeting a sub with a speed factor greater than 1. I've noticed that these are the only times I run into this problem. It also seems as though my pirate should be able to make it to these targets each time, even though they have a speed factor greater than 1 but for some reason the game doesn't let let them and cannot handle the combination of a pirate targeting a sub moving at a speed factor of 1.5 or 2. Or 3 for that matter (there are situations in which a pirate should be able to catch a smuggler theoretically although I've never been in one and it seems like it wouldn't work for the same reason it doesn't work with speed factors of 1.5 and 2).

Re: Pirate Trajectory Issue

PostPosted: Sun Aug 20, 2017 8:54 pm
by subsinker0204
dibididoo wrote:I've had this issue more than once and have posted here about it. I'm not sure whether it's a big or not. It seems like if the pirate will not be able to reach its target or if it instead retargets the sub every tick (forming a curved trajectory) that the pirate should not be able to launch at all. I think this only happens however when targeting a sub with a speed factor greater than 1. I've noticed that these are the only times I run into this problem. It also seems as though my pirate should be able to make it to these targets each time, even though they have a speed factor greater than 1 but for some reason the game doesn't let let them and cannot handle the combination of a pirate targeting a sub moving at a speed factor of 1.5 or 2. Or 3 for that matter (there are situations in which a pirate should be able to catch a smuggler theoretically although I've never been in one and it seems like it wouldn't work for the same reason it doesn't work with speed factors of 1.5 and 2).


I've encountered this problem a couple of times too. In my cases, the pirate should normally be able to intercept the sub but doesn't since the arc trail is longer than the straight line. I think you might be right about the speed having a role in the problem. Just saying, the problem isn't in the sub not being able to reach its target. At least, not in the scenarios I've encountered