Released specialists didn't return to owner

Found any bugs? Tell us!

  • I noticed something weird in my last game that I don't think was supposed to happen. I had attacked another player (Brown) and captured 3 of his specialists, all held captive at one of my bases. He attacked that base and I couldn't defend it in time, so to prevent him from getting his specialists back as quickly, I released them one tick before his sub hit (I was online at the time, there were 11 minutes left until his sub would hit the base).

    Here's what happened: the sub with the released specialists launched towards his nearest base. On the next tick, when his incoming sub collided with that sub and landed at the base, it suddenly caused the released specialists to redirect, and they changed to start heading towards one of my other bases. According to time machine they would have continued to a base under my control and would have sat there captured instead of returning to him. (This didn't happen because he had a pirate nearby and ended up intercepting the sub of released specialists to get them to return to him).

    This definitely didn't seem like intended functionality because it was essentially letting me hold on to his captured specialists - anyone else experienced something like this? I'm guessing it's similar to the saboteur bug and has to do with the fact that I launched on the last tick before he landed.
    rracer2
     
    Posts: 22
    Joined: Tue Dec 13, 2016 9:04 am


  • Not entirely sure what's going on here... pics would help us out :D
    Loki: I have an army!
    Tony Stark: We have a Discord.

    Earth's Mightiest Discord Server!

    P.S. Those are actually 2 different links
    User avatar
    mathwhiz9
     
    Posts: 3327
    Joined: Sun Nov 08, 2015 7:22 pm
    Location: The Great White North


  • rracer2 wrote:I noticed something weird in my last game that I don't think was supposed to happen. I had attacked another player (Brown) and captured 3 of his specialists, all held captive at one of my bases. He attacked that base and I couldn't defend it in time, so to prevent him from getting his specialists back as quickly, I released them one tick before his sub hit (I was online at the time, there were 11 minutes left until his sub would hit the base).

    Here's what happened: the sub with the released specialists launched towards his nearest base. On the next tick, when his incoming sub collided with that sub and landed at the base, it suddenly caused the released specialists to redirect, and they changed to start heading towards one of my other bases. According to time machine they would have continued to a base under my control and would have sat there captured instead of returning to him. (This didn't happen because he had a pirate nearby and ended up intercepting the sub of released specialists to get them to return to him).

    This definitely didn't seem like intended functionality because it was essentially letting me hold on to his captured specialists - anyone else experienced something like this? I'm guessing it's similar to the saboteur bug and has to do with the fact that I launched on the last tick before he landed.

    Yeah I guess this might be a bug.
    Imagine how stupid the average person is. Then realize that half of the people are even stupider than that.
    -George Carlin
    User avatar
    niverio
     
    Posts: 1364
    Joined: Fri Jan 15, 2016 4:51 am


  • Here are a few screenshots to explain.

    Edit: Looks like they added backwards so you'll have to look from bottom to top. Brown sent a bunch of subs to take over my outpost. I used the saboteur on the first and the double agent on the second, then released his specialists right before the third hit and took over the outpost. They were headed to his base but redirected to one of my bases when his sub took over the outpost.
    Attachments
    image.png
    His sub hits and causes the released specialists to redirect to one of my other bases instead of his.
    image.png (208.17 KiB) Viewed 1358 times
    image.png
    I release the specialists one tick before he arrives.
    image.png (202.49 KiB) Viewed 1358 times
    image.png
    Brown's subs head to take the outpost.
    image.png (196.86 KiB) Viewed 1358 times
    rracer2
     
    Posts: 22
    Joined: Tue Dec 13, 2016 9:04 am


  • That is kinda strange, yes. I think the most likely solution to your problem is that you released them only 1 tick before he arrived, because sometimes subs don't launch correctly if another sub is arriving at the same time. Other than that, I can't see anything that would cause it to do this
    Loki: I have an army!
    Tony Stark: We have a Discord.

    Earth's Mightiest Discord Server!

    P.S. Those are actually 2 different links
    User avatar
    mathwhiz9
     
    Posts: 3327
    Joined: Sun Nov 08, 2015 7:22 pm
    Location: The Great White North


  • Then I'll have to try this again in a future game - it would be great if I could release an enemy's specialists at the last second and cause them to stay captured at a different one of my outposts!
    rracer2
     
    Posts: 22
    Joined: Tue Dec 13, 2016 9:04 am


  • First of all, good job. Late releases to save time is indeed good tactics that you don't see too often.
    Second, you can indeed voluntarily release to an enemy's outpost, which you're also attacking, to keep them captive. Pretty easy to do when it's an all-out war on several outposts.

    That said, I can't explain what happened in your case. It shouldn't go towards one of *your* bases. Glitchy indeed.
    Keep up the good plays !

    TAKE.Benzedreene
    TAKE a deep breath and...
    User avatar
    benzedreene
     
    Posts: 146
    Joined: Sat May 07, 2016 5:33 am
    Location: World Wide Web


  • Thanks! Only my 6th game so I'm still learning but I feel like I've done pretty well for myself so far.
    rracer2
     
    Posts: 22
    Joined: Tue Dec 13, 2016 9:04 am



Return to Bug reports




Information
  • Who is online
  • Users browsing this forum: No registered users and 1 guest
cron